normal Phantom: OSX - No device detected; Windows: 2 Hz

01 Nov 2017 18:17 #1

Hello everybody,

i am working on a project with the haptic device Phantom OMNI from SensAble.
For about a weak I was trying to get it to work under a windows machine using
SensAble's own SDK OpenHaptics - without success. All I can use is the testing application
that comes shipped with it, no example code works if the device is plugged in.

A colleague of mine was making a project with it years ago and sent me his masters
thesis, in which I found out Chai3D exists and seems to make the Phantom useable under
OSX and offers a lot of utilities that suit my needs.

So I was hoping I could work with the Phantom and chai3D in OSX but the first
example project application shows that it doesn't detect any device.

I also tried it using (bootcamp) Windows 7 Prof. 64bit and it works at least, but
it's running very slow ..with 60fps/2Hz.. and the 2Hz I assume represents the polling rate
from the stylus position.

Does anybody know how to resolve these problems?

Kind regards,

Please Log in or Create an account to join the conversation.

07 Nov 2017 15:10 #2

I just found out that the problems I was experiencing came from Apple's FireWire interface drivers for windows bootcamp partitions. (Macbook Pro 13-inch 2012)

Everything works now, using a pure windows workstation with a onboard firewire (VIA chipset) interface.

Please Log in or Create an account to join the conversation.