normal Cannot detect the haptic device in V-REP

20 May 2017 12:13 #1

Hello everyone,

I am trying to read the Geomatic touch device in V-REP. I am using windows 10 of 64 bits, CHAI3D 3.1.1 and V-REP 3.3.2.
So far, I installed the Geomatic Touch and Open Haptics drivers. Both drivers work properly, and then I can configure the connection with the haptics device, the pairing and so on. Then, I built CHAI3D in 64 bits by using VS2015. I checked that the communication works by trying the examples of CHAI3D, all examples work properly. Then, I built the V-REP module in 64 bits and put it in the V-REP folder (by changing the output directory in VS2015). When I start V-REP I can see in the console that the plugin is correctly loaded by

Plugin 'CHAI3D': loading... 
Plugin 'CHAI3D': load succeeded.

However, when I try to run the examples that CHAI3D have with V-REP(01-V-REP-shapes.ttt and 02-V-REP-Pioneer.ttt) I always obtain the following message in the V-REP console:
Initialization failed. (simExtCHAI3D_start @ <unknown plugin>)

Does someone have any idea of which could be the issue?

Ps: I am building CHAI3D in 64 bits because in the 32 bits version the examples of CHAI3D do not work on my computer (the device is not found). Moreover, I tried also with the latest version of V-REP of 64 bits in order to have all configured in 64 bits, but I still have the same error.

Please Log in or Create an account to join the conversation.

26 May 2017 22:32 #2

Hello, I solved by myself

The solution is a kind of strange but it worked for me.
I read that CHAID 3D works well with the 32 bits version of V-REP, therefore I just compiled the library in Win32 and used it in the latest version of V-REP of 32 bits. However, the examples on the 32 bits version did not work on my PC. I needed to do some additional stuff in order to solve my problem.

NOTE: The solution includes the use of VS2013 and VS2015.

Here are the steps that I followed

  1. Install the latest 32 bit version of V-REP (in my case 3.3.2)
  2. Download the Visual studio version of CHAI 3D
  3. Compile CHAI3D in Win32 by using VS2013
  4. Compile the V-REP module in Win32 but in this case using VS2015
  5. Copy all the files on /CHAI3D/modules/V-REP/bin/win-Win32 and paste them in your installation folder of V-REP

By following these step I finally solved the issue.

Please Log in or Create an account to join the conversation.